In Stock
New
UK Free Shipping UK Free Shipping over £249
Buy 5 or More Units - Unlock Priority Discounts!
Buy 20 or More Units - Get Exclusive Volume Discounts!
Also Support:
Are you a reseller or placing a large order?
We're happy to offer Special Pricing tailored to your needs.
Click "Request Quote" or email us at [email protected]
to get your best price today!
Product Code: SWHO-838
MPN #: DGS-1250-52X
Product Condition: New
Network congestion and downtime can cripple your business, leaving users frustrated and revenue slipping away. The D-Link DGS-1250-52X 48-port Gigabit 4x10G SFP+ L3 Managed Switch is a robust, value-driven solution that consolidates high-speed connectivity, advanced routing and easy management into a single rack-mountable unit, keeping your office or data centre running smoothly.
When a growing number of devices compete for bandwidth, slow speeds and frequent outages become inevitable. This problem not only hampers productivity but also raises security risks as traffic is forced through overloaded links. The D-Link DGS-1250-52X 48-port Gigabit 4x10G SFP+ L3 Managed Switch eliminates these issues by delivering 48 Gigabit Ethernet ports plus four 10 G SFP+ uplinks, layered-3 routing and comprehensive management tools, giving you a reliable backbone that scales with your needs.
Ideal for a range of environments, this switch can be deployed in:
You gain a network that grows with your business, thanks to abundant gigabit ports and fast 10 G uplinks that prevent bottlenecks. Advanced Layer-3 routing and VLAN capabilities let you segment traffic, improving security and ensuring that voice, video and critical data receive the priority they need. The intuitive web interface and D-Link Network Assistant simplify configuration, so you can set up or troubleshoot the switch without specialist knowledge, reducing downtime and IT costs. Dual image functionality provides a safety net, allowing swift recovery from firmware issues and keeping your operations running uninterrupted. Overall, the switch delivers enterprise-level performance and reliability at a price that protects your budget.
| Management features | |
| MIB support | RFC2893, RFC4213, RFC4291, RFC2464, RFC2462, RFC4862, RFC2461, RFC4861, RFC2573, RFC1321, RFC2284, RFC2865, RFC2716, RFC3580, RFC826, RFC2463, RFC4443, RFC792, RFC793, RFC768, RFC791, RFC2389, RFC4113, RFC4022, RFC2618, RFC2674, RFC1398, RFC1643, RFC1650, RFC2358, RFC2665, RFC2021, RFC271, RFC1757, RFC2819, RFC1442, RFC1901, RFC1902, RFC1903, RFC1904, RFC1905, RFC1906, RFC1907, RFC1908, RFC2578, RFC3418, RFC2573, RFC2575, RFC2576, RFC1212, RFC1213, RFC1215, RFC1493, RFC1157, RFC2620, |
| System event log | Yes |
| ARP inspection | Yes |
| Configuring Location Settings (CLI) | Yes |
| Web-based management | Yes |
| Quality of Service (QoS) support | Yes |
| Switch layer | L3 |
| Switch type | Managed |
| Ports & interfaces | |
| Console port | RJ-45 |
| SFP+ module slots quantity | 4 |
| Installed SFP+ modules quantity | 0 |
| Installed SFP modules quantity | 0 |
| Basic switching RJ-45 Ethernet ports type | Gigabit Ethernet (10/100/1000) |
| Basic switching RJ-45 Ethernet ports quantity | 48 |
| Network | |
| Number of VLANs | 4094 |
| Virtual LAN features | Voice VLAN |
| VLAN support | Yes |
| Auto MDI/MDI-X | Yes |
| Broadcast storm control | Yes |
| Flow control support | Yes |
| Head-of-line (HOL) blocking | Yes |
| Link aggregation | Yes |
| Spanning tree protocol | Yes |
| 10G support | Yes |
| Networking standards | IEEE 802.1D, IEEE 802.1Q, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.3, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3ae, IEEE 802.3az, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z |
| Optical fiber | |
| Fiber ethernet cabling technology | 100BASE-FX, 1000BASE-LHX, 1000BASE-X, 1000BASE‑LX, 1000BASE‑SX, 1000BASE‑ZX |
| Data transmission | |
| Packet buffer memory | 16 MB |
| Jumbo frames | 12000 |
| Jumbo frames support | Yes |
| Number of static routes | 124 |
| Static route | Yes |
| Forwarding rate | 130.95 Mpps |
| Switching capacity | 176 Gbit/s |
| MAC address table | 32000 entries |
| Security | |
| IP-MAC-Port binding | Yes |
| Loop protection | Yes |
| Queue scheduling algorithms | Weighted Round Robin (WRR) |
| Security algorithms | EAP, LEAP, MD5, PEAP, SSH, SSL/TLS, TTLS |
| IGMP snooping | Yes |
| Access Control List (ACL) rules | 768 |
| Access Control List (ACL) | Yes |
| DHCP features | DHCP client, DHCP server, DHCP snooping |
| Multicast features | |
| Multicast support | Yes |
| Design | |
| Electromagnetic compatibility | CE A, VCCI A, FCC A, IC, BSMI |
| LED indicators | Activity, Link, Power, Speed |
| Product colour | Black |
| Rack mounting | Yes |
| Performance | |
| Mean time between failures (MTBF) | 589984.72 h |
| Noise level | 50.7 dB |
| Flash memory | 64 MB |
| Internal memory | 2048 MB |
| Memory type | DDR3-SDRAM |
| Power | |
| Power consumption (max) | 51.2 W |
| AC input frequency | 50 - 60 Hz |
| AC input voltage | 100 - 240 V |
| Power supply included | Yes |
| Power over Ethernet (PoE) | |
| Power over Ethernet (PoE) | No |
| Operational conditions | |
| Heat dissipation | 174.592 BTU/h |
| Operating temperature (T-T) | -5 - 50 °C |
| Storage relative humidity (H-H) | 0 - 95% |
| Operating relative humidity (H-H) | 0 - 95% |
| Storage temperature (T-T) | -20 - 70 °C |
| Operating temperature (T-T) | -5 - 50 °C |
| Weight & dimensions | |
| Weight | 3.01 kg |
| Height | 44 mm |
| Depth | 210 mm |
| Width | 440 mm |
| Packaging data | |
| Package weight | 4.28 kg |
| Package height | 91 mm |
| Package depth | 565 mm |
| Package width | 351 mm |
| Certificates | |
| Certification | CB, UL, BSMI, CCC |
| Technical details | |
| Master (outer) cases per pallet (air) | 16 pc(s) |
| Master (outer) cases per pallet (sea) | 16 pc(s) |
| Pallet gross length | 110 cm |
| Pallet gross weight (air) | 382.7 kg |
| Pallet gross weight (sea) | 382.7 kg |
| Pallet gross width | 120 cm |
| Pallet height (air) | 167.1 cm |
| Pallet height (sea) | 167.1 cm |
| Products per pallet (air) | 80 pc(s) |
| Products per pallet (sea) | 80 pc(s) |
| Products per shipping (inner) case | 5 pc(s) |
| Shipping (inner) case gross weight | 22.8 kg |
| Shipping (inner) case height | 38.4 cm |
| Shipping (inner) case length | 58.5 cm |
| Shipping (inner) case net weight | 18.3 kg |
| Shipping (inner) case width | 47.8 cm |
| Logistics data | |
| Harmonized System (HS) code | 85176990 |
| Summary Details | |
| Networking standards | IEEE 802.1D |
No Attachments Found!
Be the first to write a review
We are retiring PICOPC Products MNHO-073, MNHO-048 and MNHO-043 and they have reached EOL (End Of Life) as we are introducing new products with better technology. We would recommend you to look into MNHO-095. For Untangle, pfSense, OPNsense, Windows 11, Proxmox VE etc. we recommend MNHO-095 whereas for Sophos, Kerio Control and Endian, we would recommend MNHO-069. (A complete list of supported OS can be found in each product's listing)